How To Fix Photo Library Not Showing In iMovie Library

So, after I upgraded to macOS High Sierra 10.13, the Photos app updated and iMovie no longer attached it in the Library. What I had to do is to set “Use as system photo library” in the Photos preferences, but it was grayed out. In order to reset this, I had to launch Photos with the option key pushed and a menu will come up, create a new library. After created a new library, open it up go to preferences, set Use as system photo library and the new one shows up in the iMovie. Now, I open the original Photo Library with Photos, go to preferences and the option Use as system photo library available, set it and my old Photo Library appear again in iMovie. Delete the new library.

Use As System Photo Library

3 Replies to “How To Fix Photo Library Not Showing In iMovie Library”

  1. Your instructions are simply not clear. I want to follow them but I cannot as there is a risk of losing all photo files. There must be some resource on-line that clearly states how to fix an incomprehensible problem. Incomprehensible because Apple has managed to create programs (iMovie and Photos) that are incompatible, upgrades that are mysterious and cause reduction in performance. (like OS Mojave). I would suggest that you ask a proofreader/editor to review your writing prior to publishing. Thanks.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.