Install XAMPP 1.8.3 And WordPress 3.9 On Mac OS X Mavericks 10.9.2

On the new XAMPP 1.8.3 and WordPress 3.9, there are a few problems that need to be addressed before we can really use the 2 systems perfectly on Mac OS X, especially Mavericks 10.9.2. Xampp installer will install Xampp folder in the Application folder, this causes permission problems. To fix these problems, we need to add some scripts to the wp-config.php. ***When you copy and paste the codes, you may have to retype due to characters difference***

z_script_required     z_bad_characters

z_import_installed

    define(‘FTP_HOST’, ‘localhost’);

    define(‘FTP_USER’, ‘daemon’);

    define(‘FTP_PASS’, ‘xampp’);

    if(is_admin()) {

        add_filter(‘filesystem_method’, create_function(‘$a’, ‘return “direct”;’ ));

        define( ‘FS_CHMOD_DIR’, 0751 );

    }

One Reply to “Install XAMPP 1.8.3 And WordPress 3.9 On Mac OS X Mavericks 10.9.2”

  1. Pingback: How To Install XAMPP 1.8.3-4 And WordPress 3.9 On Mac OS X 10.9.2 | Wordpress Tutes

Leave a Reply

Your email address will not be published. Required fields are marked *